Kirix Support Forums

wxWebConnect On Linux & AUI strange resize bug

Please post all general questions, comments, bug reports, and any other wxWebConnect feedback here.

wxWebConnect On Linux & AUI strange resize bug

Postby mgsutton on Fri Oct 23, 2009 6:19 pm

I've written an app that uses wxWebConnect inside an AUI Notebook. It works great on Windows, but on Linux it seems to have a very strange resize issue. I can only get the wxWebConnect control to appear if I very precisely resize the pane so that I drag it over and back before releasing the mouse. This seems to generate a double resize event with exactly the same height and width. (I've been logging resize data inside the OnSize function) Only when this occurs, that is, the panel receives two resize events with the same height and width will the wxWebConnect control appear. I've tried every combination of forcing a repaint inside the OnSize event that I can think of to no avail. Any thoughts or help would be much appreciated.
Thanks again for a great control!
Registered User
Posts: 4
Joined: Fri Jul 24, 2009 4:08 pm

Re: wxWebConnect On Linux & AUI strange resize bug

Postby Ben on Sat Oct 24, 2009 4:27 am

Hi Matt,

We've not quite cleared up the resize problems on linux. I think it's due to some kind of cached size, but am not yet sure. With flash controls in the web page it's even worse. I'm currently getting xulrunner 1.9.1 up and running with wxWebConnect, and will see if the problem still exists with that version.

Ben Williams
Kirix Support Team
User avatar
Kirix Support Team
Posts: 525
Joined: Mon Dec 19, 2005 6:29 am

Re: wxWebConnect On Linux & AUI strange resize bug

Postby dogantd on Fri May 28, 2010 7:21 am


I have the same problem. On Windows, there is no problem. But on Linux, when browsing pages which contains flash or java applets I have to resize window manually. I am testing with xulrunner 1.9.3 and wxWidget 2.8.11.


Registered User
Posts: 1
Joined: Fri May 28, 2010 7:12 am

Return to wxWebConnect Questions, Thoughts & Feedback