Kirix Support Forums

sqlite error when using webcontrol

Please post all general questions, comments, bug reports, and any other wxWebConnect feedback here.

sqlite error when using webcontrol

Postby ron on Sun Mar 27, 2011 4:17 am

We were successfully using a prior version of the webcontrol in our application. But today I integrated the 1.1 version and now when starting my app I get the xulrunner message:

Code: Select all
    SQLite Version Error
   The application has been updated, but your version of SQLite is too old and the application cannot run.

This is on Kubuntu 10.10, all libs are the latest. The specific sqlite being loaded is in "/usr/lib/", which is 3.7.2. "xulrunner" is the system "xulrunner-1.9.2" (or it's supposed to be, anyway)

The thing I don't understand is that both xulrunner and sqlite3 are from the system repos, and they do work (and so does Firefox).

The reason this is a problem is that due to licensing issues, we cannot bundle 'xulrunner' with our application. Any ideas?
Registered User
Posts: 1
Joined: Sun Mar 27, 2011 4:12 am

Re: sqlite error when using webcontrol

Postby Ben on Mon Mar 28, 2011 5:16 am

Interesting problem. As you know, Mozilla links to libsqlite. I doubt that this is a dependency problem in the system repo. Does your application also directly link to a non-system version of sqlite?

In any case, solving this library dependency issue would solve this particular problem.

Ben Williams
Kirix Support Team
User avatar
Kirix Support Team
Posts: 525
Joined: Mon Dec 19, 2005 6:29 am

Return to wxWebConnect Questions, Thoughts & Feedback