Kirix Support Forums

Visual bug

Please post all general questions, comments, bug reports, and any other wxAUI feedback here.

Visual bug

Postby juan on Sun Feb 04, 2007 9:14 am

Hello

I found a bug in the auidemo sample provided with wxWidgets. When docking the "Text Pane with Hide Prompt" pane under the "Tree Pane" one, a small line of rubbish appears below it.

Thank you for this great library!

Image
juan
Registered User
 
Posts: 2
Joined: Sun Jan 01, 2006 10:26 am

Postby Ben on Mon Feb 05, 2007 5:27 am

Hi there,

This is sadly due to a rounding error in wxSizer. I haven't really decided what to do about it yet, but didn't want to have it delay the release of the library. There are a number of options I'm considering.

Thanks for your report.

Ben
User avatar
Ben
Kirix Support Team
 
Posts: 522
Joined: Mon Dec 19, 2005 6:29 am

Re: Visual bug

Postby Huge on Mon Jul 16, 2007 9:06 am

Hi,
I have submitted a patch for this. It is only a couple of lines.
See this for more details:

http://sourceforge.net/tracker/index.php?func=detail&aid=1754785&group_id=9863&atid=309863
Huge
Registered User
 
Posts: 25
Joined: Thu Dec 28, 2006 1:12 am

Re: Visual bug

Postby Ben on Thu Jul 19, 2007 8:13 am

Thanks, Huge, for fixing this.

Best,
Ben
Ben Williams
Kirix Support Team
User avatar
Ben
Kirix Support Team
 
Posts: 522
Joined: Mon Dec 19, 2005 6:29 am

Re: Visual bug

Postby Huge on Thu Jul 19, 2007 8:31 pm

Apparently it has been put in the 2.8 branch, and has been fixed by other means in the trunk.
Huge
Registered User
 
Posts: 25
Joined: Thu Dec 28, 2006 1:12 am

Return to wxAUI Questions, Thoughts & Feedback