Kirix Support Forums

In ubuntu 6.06,Kirix wouldn't work

Please post any help questions, requests or other feedback here.

In ubuntu 6.06,Kirix wouldn't work

Postby paulcross on Wed Mar 12, 2008 1:23 pm

paul@zz:~/Desktop$ cd strata_setup
paul@zz:~/Desktop/strata_setup$ sudo ./setup
./setup: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required b y ./setup)
paul@zz:~/Desktop/strata_setup$ sudo ./setup
Segmentation faults
paul@zz:~/Desktop/strata_setup$

At first it couldn't find a libc of 2.4 version , so I managed to downloaded a "glibc-32bit-2.4-31.43.6.x86_64.rpm" package
and put it into the "/lib/tls/i686/cmov" directory.Now I have the new error message:Segmentation faults.

What should I do?
Do I have to reinstall my whole system?
paulcross
Registered User
 
Posts: 1
Joined: Wed Mar 12, 2008 12:30 pm

Re: In ubuntu 6.06,Kirix wouldn't work

Postby Ben on Thu Mar 13, 2008 3:32 pm

Hello,

You'll need to install the glibc 2.4 package in order to make Kirix Strata work on your system. Because Ubuntu is debian-based, unless you've installed rpm, that rpm file you have probably won't work. I would uninstall it. There are packages available for Ubuntu to install glibc 2.4.

Other than that, my only other recommendation is that you upgrade to a newer Ubuntu distribution. It's quite easy to upgrade, and you don't need to reinstall your whole system see "apt-get dist-upgrade"

All the best,
Ben
Ben Williams
Kirix Support Team
User avatar
Ben
Kirix Support Team
 
Posts: 522
Joined: Mon Dec 19, 2005 6:29 am

Return to Strata Help & Feedback