Kirix Support Forums

Having trouble building wxWebConnect in Linux

Please post all general questions, comments, bug reports, and any other wxWebConnect feedback here.

Having trouble building wxWebConnect in Linux

Postby whatisron on Tue Feb 16, 2010 3:03 am

I have a wxWidgets application that I wanted to use wxWebConnect. I built the libraries in Windows, got my application to successfully use wxWebConnect. But now I'm trying to port to RHEL. I already have my application working on RHEL, except for the wxWebConnect portion.

The instructions for building under Linux are a bit scant. It says:

1) Unzip the archive into /home/user/webconnect... so I unzipped it into my home folder.
2) Install wxWidgets in webconnect/wxWidgets... since I already have wxWidgets installed I figured I'd update the Makefile instead
3) Run make... I did. It gives an error looking for top.mak. If I comment that out, it seems to start building but starts outputting many thousands of lines of code, etc., finally failing on the ar command... because actually it doesn't seem to have built anything. What is top.mak? It doesn't seem to appear in the wxWidgets directory or the wxWebConnect folder.

Now the folder that has the cpp/h files also has a Visual Studio project. I take it the download for Windows is the same as the download for Linux (i.e. 1 download is supposed to work on both platforms).

-A little lost...
Registered User
Posts: 3
Joined: Fri Feb 12, 2010 11:46 pm

Return to wxWebConnect Questions, Thoughts & Feedback